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About the Speaker

Assistant Professor, CSED, Thapar Institute of Engineering
& Technology, Patiala, Punjab.
PhD and MTech, ABV-IIITM Gwalior.
Project Scientist, SCF-Bio, IIT Delhi (1yr 8m).
Software Engineer, Amdocs, Pune (2yr 6m) .

Area of Research:

Machine Learning and Data Mining.
Soft Computing (GA, PSO, DE, ABC).
Combinatorial Problems.
Modelling and Simulations.
Bioinformatics.

Contact: psrana@gmail.com, 9855764471 / 9313889932
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Learning by Doing
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Latex: Workshop content
Latex: Software Requirement
Latex: Installation
Latex: Environment Setup

Latex: Workshop content

1 01 - Latex Setup directory
Contain Latex setup.

2 02 - Practical Session directory
Contain all practical sessions.

3 Latex Workshop PPT.pdf file
PPT of the Latex workshop.
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Latex: Workshop content
Latex: Software Requirement
Latex: Installation
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Latex: Software Requirements

1 Miktex: Latex Compiler
2 WinEdt: Latex Editor
3 Ghost Script: Post Script / PDF interpreter
4 Gimp: Image Editor similar to photoshop
5 Adobe Reader: PDF Viewer
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Latex: Workshop content
Latex: Software Requirement
Latex: Installation
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Latex: Installation

Go to 01 - Latex Setup directory and install all software.

1 01 - MikTex
(Right click on setup file → ”Run as Administrator”)

2 02 - Ghost Script
3 03 - Gimp
4 04 - PDF-Reader-SumatraPDF
5 05 - Winedt

(Tick the Associate Tex Filetypes with WinEdt)
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Latex: Workshop content
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Latex: Environment Setup

Internet Setting for Package Manager for Automatic
download and Install the required packages.

Press ”Windows Key” and write ”Miktex”.

Dr. Prashant Singh Rana Latex Workshop 9/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Latex: Workshop content
Latex: Software Requirement
Latex: Installation
Latex: Environment Setup

Latex: Getting Started

1 Open Latex Workshop directory

2 Go to Practical Session → Session I-A

3 Open main.tex with WinEdt
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Latex: First Document
Latex: Second Document

Latex: Setting I

Compilation Setting for WinEdt.
Click on Options → Execution Modes → Tex Options

If all your figures are in eps → Choose ”dvi → ps → pdf”

If all your figures are in png or jpg → Choose ”Default (PDFTeXify)”
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Latex: First Document
Latex: Second Document

Latex: Setting II

PDF Viewer Setting.

Click on Options → Execution Modes → PDF Viewer →
Browse Sumatra PDF file location → Apply → OK
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Latex: First Document
Latex: Second Document

Latex: First Document

Compile the document.
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Latex: First Document
Latex: Second Document

Latex: First Document

Output is a PDF file. Explore it.
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Latex: First Document
Latex: Second Document

Latex: First Document

Resize the window of WinEdt and Sumatra PDF.
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Latex: First Document
Latex: Second Document

Latex: First Document

Edit the title, author, affiliation, email and compile.

Add new section.
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Latex: First Document
Latex: Second Document

Latex: First Document

To make Bold : \textbf{ << yourtext >> }

To make Italic: \emph{ << yourtext >> }

To make Underline: \underline{ << yourtext >> }

Make the title BOLD, author name Italic and Underline
the email id.

Compile it again.
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Latex: First Document
Latex: Second Document

Latex: First Document
1 Error generation and correction.
2 Compile again in error mode.
3 To come out from the error mode - write ”e/x and press

enter” or press ”Red Cross”.
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Latex: First Document
Latex: Second Document

Latex: Second Document
1 Open Latex Workshop directory

2 Go to Practical Session → Session I-B

3 Open Second.tex with WinEdt
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Latex: First Document
Latex: Second Document

Latex: Second Document

Compile the document.
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Latex: First Document
Latex: Second Document

Latex: Second Document

Output is a PDF file. Explore it.
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Latex: First Document
Latex: Second Document

Latex: Second Document

Edit the title, author, affiliation, email and compile.
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Latex: First Document
Latex: Second Document

Latex: Tips and Trick

1 Compile and Run after every minor changes.
2 To make comments use: %

To write 70% 70\% is used.

3 To add new line: \\ or \newline.

4 & is a special character used in table, to write &, use \&.

5 To give horizontal space use \hspace*{1cm}.

6 To give vertical space use \vspace*{1cm}.

7 Always use Template.
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Latex: First Document
Latex: Second Document

Latex: Second Document
Key Point 1: Document Class \documentclass{ }

1 Also known as class file.

2 Define the formatting of the document.

3 File extension is .cls

4 Edit the class file as per your requirement.

5 Find out the document class used in the document.
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Latex: First Document
Latex: Second Document

Latex: Second Document

Key Point 2: Use Package \usepackage{ }
1 Similar to header file in C/C++ i.e. #include<stdio.h>.
2 Used to add special features e.g Algorithms, Long table,

Landscape the page, etc.
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Latex: First Document
Latex: Second Document

Latex: Second Document

Key Point 3: Begin Document . . . . . . End Document

\begin{document}
. . .
All contents are defined here.
. . .
\end{document}
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Latex: First Document
Latex: Second Document

Quiz I
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Latex: First Document
Latex: Second Document

End of Session I
Latex Installation and Environment Setup
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Session II
Resume Writing
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Resume Writing

Go to Practical Session → Session II

Open Resume2.pdf and explore it.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Resume Writing

Open Resume.tex with WinEdt and explore it.

Compile the Resume.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Resume Writing

Output is a PDF file, explore it.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Resume Writing

Edit the Name, Contact, Email and Compile again.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Resume Writing

Edit the following details and compile again.
1 Education
2 Personal Details
3 Skill Sets
4 . . .
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

End of Session II
Resume Writing
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Session III
Report/Sypnosis Writing

Dr. Prashant Singh Rana Latex Workshop 37/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session
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Demo I: Get Image from Excel
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Report Writing

File Information
1 .tex: Main document file.
2 .bib: Bibliography/Reference file.
3 .bst: Bibliography/Reference style file.
4 .cls: Class file (required for formatting).
5 .sty: Style file (for adding features in your report).
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Report Writing

Go to Practical Session → Session III-A

Open Report2.pdf and explore it.

Table of Contents.

List of Figures.

List of Tables.

Sections.

References.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
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Report Writing

Open Report.tex with WinEdt and explore it.

Compile the Report.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Report Writing

Output is a PDF file, explore it.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Report Writing

Edit the Title, Author, Reg. No and compile again.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Report Writing

Edit the following

Supervisor Name

Department Name

Institute Name

Degree

Start Degree

End Degree

Compile again.
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Demo I: Get Image from Excel
Demo II: Convert Image to eps

Report Writing: Layout

Dr. Prashant Singh Rana Latex Workshop 44/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Report Writing: Layout

Dr. Prashant Singh Rana Latex Workshop 45/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Demo I
Get Image from Excel
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Demo I: Get Image from Excel

1 Go to Practical Session →
Session III-B - Demo - Image → Demo I

2 Open Result.xlsx.
3 Draw the scatter plot.
4 Save As the file as Web Page.
5 One folder and one HTML file will be created.

Open the folder and explore the images.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

Tips

1 You can extract all images from Word, Power Point and
Excel.

2 Just Save As the file as Web Page.
3 One folder and one HTML file will be created.

Open the folder and explore the images.
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Demo II
Convert Image to eps
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Demo II: Convert Image to eps

eps is encapsulated postscript.

Tools for file conversion:
1 SmartDraw.

2 Photoshop.

3 CorelDraw.

4 GIMP.

5 Online Tools.
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Report Writing
Demo I: Get Image from Excel
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Demo II: Convert Image to eps

1 Go to Practical Session → Session III-B → Demo II
2 Open Figure.png with GIMP.

or Right Click on image → Edit with GIMP.
3 File → Export As →”Add .eps in the file name” → Export.
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Report Writing: Exercise

Change the logo in the report.
1 Download Institute Logo.
2 Convert it to eps.
3 Add in the report without file extension.
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Demo I: Get Image from Excel
Demo II: Convert Image to eps

Report Writing: References

Go to end of the tex file.

Key Points:
1 Store all the references.
2 Also known as bib file (or references file).

3 File extension is .bib.
4 Explore the bib file in WinEdt.
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Resume Writing
Report Writing
Demo I: Get Image from Excel
Demo II: Convert Image to eps

End of Session III
Report Writing
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Thesis Writing
Paper Writing
Presentation Preparation

Session IV
Thesis Writing
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Thesis Writing

Go to Practical Session → Session IV

Open Thesis2.pdf and explore it.

Table of Contents.

List of Figures.

List of Tables.

Sections.

References.
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Thesis Writing
Paper Writing
Presentation Preparation

Thesis Writing

Open Thesis.tex with WinEdt and explore it.

Compile the Thesis.
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Paper Writing
Presentation Preparation

Thesis Writing

Output is a PDF file, explore it.
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Thesis Writing

Edit the Title, Author and Reg. No and compile it again.
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Paper Writing
Presentation Preparation

Thesis Writing

Edit the following

Supervisor Name

Department Name

Institute Name

Degree

Start Degree

End Degree

and compile it again.
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Thesis Writing
Paper Writing
Presentation Preparation

Thesis Writing: Layout
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Thesis Writing: Layout

Every chapter have different tex file.
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Thesis Writing: Tips

Every Chapter have different tex file.
Comment/UnComment those files required at a time.

Make the changes in the required file; save the changes
and compile the main file (i.e. Thesis.tex).

Changes will be the reflected if the file remain unsaved.

Dr. Prashant Singh Rana Latex Workshop 63/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Thesis Writing
Paper Writing
Presentation Preparation

End of Session IV
Thesis Writing
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Thesis Writing
Paper Writing
Presentation Preparation

Session V
Paper Writing
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Thesis Writing
Paper Writing
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Paper Writing: IEEE

Go to Practical Session →
Session V - Paper Writing - 01

Open IEEE Sample.tex with WinEdt.

Compile, explore and make the required changes.
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Paper Writing: Springer

Go to Practical Session →
Session V - Paper Writing - 02

Open Springer Sample.tex with WinEdt.

Compile, explore and make the required changes.
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Paper Writing: Elsevier

Go to Practical Session →
Session V - Paper Writing - 03

Open Elsevier Sample.tex with WinEdt.

Compile, explore and make the required changes.
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Thesis Writing
Paper Writing
Presentation Preparation

Paper Writing: Tips and Tricks

Download the template from Journal home page.

First compile the template and start writing.
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Thesis Writing
Paper Writing
Presentation Preparation

How to convert paper to other format?

1 Add all authors, email ids, affiliations, etc in the target
tex file and compile.

2 Copy title, abstract and use packages from tex file; paste
to the target tex file.

3 Copy all the files (figures, bib, other) from source
directory to target directory.

4 Copy from section 1 to conclusion from source tex file;
paste to the target tex file and compile.

5 Change bibliography file name in target tex file and
compile.
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Thesis Writing
Paper Writing
Presentation Preparation

End of Session V
Paper Writing
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Thesis Writing
Paper Writing
Presentation Preparation

Session VI
Presentation Preparation
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Presentation Preparation

Go to Practical Session → Session VI

Open Thesis PPT2.pdf and explore it.

beamer class is required for the presentation.
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Presentation Preparation

Open Thesis PPT.tex with WinEdt.

Compile, explore it and make the required changes.
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Presentation Preparation

Edit the Title, Author and Reg. No and compile it again.
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Practical Session

Go to Practical Session → Session I-B.

Open Second.tex with WinEdt and compile it.

Dr. Prashant Singh Rana Latex Workshop 78/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Practical Session I
Working with Equations
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Equation: Basics
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Adding Equation through WinEdt

Go to Insert → Environments → Equation
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Equation: Example 1
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Equation: Example 2
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Equation: Example 3
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Equation: Error
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Adding Symbol

1 Go to View → TeX GUI Symbols
2 Place the curser where you want the symbol and then click

on the symbol.

Dr. Prashant Singh Rana Latex Workshop 86/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Equation: Example 4
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Use of Label

Label is used for cross referencing.
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Cross Reference: Example 1
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Labelling Standards
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Cross Reference: Example 2
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No Number Equation
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Special Expression 1

1 Special expression must put between $ . . . . . . $ in the
statement.
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Special Expression 2
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Multi-line Equations

1 Explore: Link1 Link2
2 Go to Google and Explore.
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Equation: Assignments

Hint: All the equations are used in the report.
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Equation: All Solutions
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End of Practical Session I
Working with Equations
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Working with WinEdt editor
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Working with WinEdt editor

Lists: Enumerate, Itemize

Symbols

Alignment: Centre, Left, Right

Clean: Removal of temp files

View PDF

Font: Bold, Italic, Underline.
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Working with WinEdt editor

Lists: Itemize
1 Go to Insert → Lists → Itemize
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Lists: Enumerate
1 Go to Insert → Lists → Enumerate
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Symbols

Dr. Prashant Singh Rana Latex Workshop 103/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Working with WinEdt editor

Alignment
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Working with WinEdt editor

Clean: Remove temp files.

Dr. Prashant Singh Rana Latex Workshop 105/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Working with WinEdt editor

PDF: To view pdf file.
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Working with WinEdt editor

Font: Italic, Bold, Underline.
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Font Size
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Font Size
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Working with WinEdt editor

Tree View: To explore report.
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Working with WinEdt editor
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End of Practical Session II
Working with WinEdt
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Figures: Basics
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Adding Figure through WinEdt

Go to Insert → Objects → Figure
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Figure: Example 1
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Figure: Example 2
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Figure: Example 3
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Position setting for Figures
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Figure in Single Column

*Useful in two column papers e.g. IEEE.
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Figure: Landscape
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Figure: Center Landscape
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Working with Figures
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Table: Basics
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Adding Tabular through WinEdt

Go to Insert → Tables → Tabular

Dr. Prashant Singh Rana Latex Workshop 130/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 1

Dr. Prashant Singh Rana Latex Workshop 131/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 2

Dr. Prashant Singh Rana Latex Workshop 132/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 3

Dr. Prashant Singh Rana Latex Workshop 133/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 4

Dr. Prashant Singh Rana Latex Workshop 134/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 5

Dr. Prashant Singh Rana Latex Workshop 135/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 6

Dr. Prashant Singh Rana Latex Workshop 136/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 7

Dr. Prashant Singh Rana Latex Workshop 137/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Table: Example 8

Dr. Prashant Singh Rana Latex Workshop 138/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

More on Tables
1 Explore: Link1
2 Go to Google and Explore.
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Table: Adding Caption
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Adding Table through WinEdt

Go to Insert → Objects → Table
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Demo: Create table from excel
1 Go to Practical Session →

Session VII - Demo - Create Table
2 Open Result.xlsx.
3 Convert (add column of &)
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Demo: Create table from excel
1 Create tabular: Copy from excel and paste.
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Demo: Create table from excel
1 Add table, caption and label.
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Long Table: Table in multiple pages

\usepackage{longtable}
Go to Practical Session →
Session III-A - Report Writing
Open Report.tex and search for longtable.
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Position setting for Tables
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Table in Single Column

*Useful in two column papers e.g. IEEE.
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Table: Landscape
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Table: Center Landscape
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Working with Tables
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End of Practical Session IV
Working with Tables
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Working with References
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References: Basics
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References: IEEE

Go to Practical Session →
Session V - Paper Writing - 01

Open IEEE Sample.tex with WinEdt.

Compile.
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References: IEEE

Go to end of the tex file.
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References: IEEE

Try For
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Try For
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References: IEEE

Explore bib file. First, click on tree view and then
reference
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bib and bbl file

.bib contain all the references.

.bbl contain only those references that are used in
the tex file.
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Adding References

Go to Google Scholar
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Adding References

Search for some key word.
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Adding References

Click on Cite.
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Click on BibTex.
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Select all and Copy.
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Adding References

1. Open bib file in Winedt.
2. Paste the new reference entry.
3. Copy the KEY.
4. Save the bib file.
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Go to tex file and paste where you want to cite.

Example: \cite{ KEY}

Dr. Prashant Singh Rana Latex Workshop 166/172



Latex Installation and Environment Setup
Latex: First Document

Resume Writing and Report Writing
Thesis Writing, Paper Writing & PPT

Practical Session

Working with Equations
Working with WinEdt
Working with Figures
Working with Tables
Working with References

Adding References

Save it and compile it again.
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Add one more reference.
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Common Problem with References
1 ?? is come at the place of newly added reference.
2 Newly added reference is not visible.

Solution:
1 Clean: Removal of temp files and Compile 2-3 times.

2 Save the bib file and Compile 2-3 times.
3 Issue occur with the new reference only.
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End Practical Session V
Working with References
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End of Latex Worshop
Thanks

Contact: psrana@gmail.com, 9855764471 / 9313889932
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